Está disponível para download a versão 0.3 do Zabbix-CAT.  Novidades da versão:

  • Instalação através de patch;
  • Implementação de controle de segurança padrão do Zabbix para hosts e grupos;
  • Suporte a listagem de todos os hosts;
Existe aqui no blog um post sobre como proceder para gerar patch e sobre como instalar o Zabbix-CAT via patch. O processo é bem simples :
  1. Baixe o patch 0.3 do nosso site e descompacte-o para o diretório home do usuário que irá atualizar o ambiente;
  2. Vá até o diretório onde estão os arquivos do frontend do Zabbix (no meu caso /usr/share/zabbix);
  3. Execute:
    patch < ~/zabbix-cat-0.3.patch
Desta forma você irá atualizar o seu ambiente sem necessitar modificar manualmente nenhum arquivo do frontend do Zabbix.
Estamos estudando novas funcionalidades para as próximas versões do add-on. Tem uma idéia ? Contribua com a comunidade !!!
Para efetuar download desta versão clique {filelink=3}
Dentro deste pacote no formato ZIP existem dois arquivos, o arquivo de patch para instalação semi-automática e o arquivo original do relatório para instalação manual.
Lembrem-se sempre de guardar a documentação para este post pois na próxima vez que vocês atualizarem o código fonte do frontend do Zabbix vocês terão que re-instalar os Add-ons visto que as customizações serão sobrepostas enquanto ele não for (se é que um dia virá a ser) uma customização (patch) aceito e integrado ao pacote padrão do Zabbix.
Nas próximas semanas estarei postando novidades sobre customizações para o Zabbix e alguns scripts para monitoração de serviços e servidores.

2 thoughts on “Zabbix-CAT – Versão 0.3

  1. Boa tarde Spinola,
    Parabéns pelo site…

    Minhas configurações são:

    4 processadores
    Meu SO é Ubuntu 11.4
    2 GB de memória

    estou com dúvidas referente a aplicação deste patch, pois tentei instalar na versão 1.8.8, porém não deu certo, apresentaram diversas opções de erro:

    pg_query(): Query failed: ERROR: syntax error at or near “`” LINE 1: …a.applicationid as id, a.name as description from `applicati… ^ [include/db.inc.php:445]
    Error in query [select a.applicationid as id, a.name as description from `applications` a inner join `hosts` h on h.hostid = a.hostid where a.`hostid` = 0 order by 2 ] [ERROR: syntax error at or near “`” LINE 1: …a.applicationid as id, a.name as description from `applicati… ^]
    pg_fetch_assoc() expects parameter 1 to be resource, boolean given [include/db.inc.php:619]
    pg_free_result() expects parameter 1 to be resource, boolean given [include/db.inc.php:621]
    pg_query(): Query failed: ERROR: syntax error at or near “`” LINE 1: …ect it.itemid as id, it.description, it.key_ from `items` it… ^ [include/db.inc.php:445]
    Error in query [select it.itemid as id, it.description, it.key_ from `items` it inner join `items_applications` ia on ia.itemid = it.itemid and `applicationid` = 0 and it.status < 1 order by 2 ] [ERROR: syntax error at or near "`" LINE 1: …ect it.itemid as id, it.description, it.key_ from `items` it… ^]
    pg_fetch_assoc() expects parameter 1 to be resource, boolean given [include/db.inc.php:619]
    pg_free_result() expects parameter 1 to be resource, boolean given [include/db.inc.php:621]

    Desde já agradeço

Deixe uma resposta para Fabiano Martins Cancelar resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *